ContextualHelp Class

Contains the details for how Revit should allow invocation of contextual help for an item added by an application.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.UIContextualHelp

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ContextualHelp

The ContextualHelp type exposes the following members.

Constructors
 NameDescription
Public methodContextualHelpConstructs a contextual help object.
Top
Properties
 NameDescription
Public propertyHelpPathThe context id, help URL, or help file path.
Public propertyHelpTopicUrlThe help topic URL.
Public propertyHelpTypeThe contextual help type.
Top
Methods
 NameDescription
Public methodLaunchLaunches and displays the help topic specified by the contents of this ContextualHelp object.
Top
Remarks
An instance of this class may be used to assign a contextual help location to any RibbonItem (through the RibbonItem.SetContextualHelp() method). It is also possible to use an instance of this class to launch the help path and topic at any time (this permits association of help topics with user interface components inside dialogs created by the add-in application).
See Also