ContextualHelpHelpTopicUrl Property |
The help topic URL.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic string HelpTopicUrl { get; set; }
Public Property HelpTopicUrl As String
Get
Set
public:
property String^ HelpTopicUrl {
String^ get ();
void set (String^ value);
}
member HelpTopicUrl : string with get, set
Property Value
String
RemarksApplies only to objects of type ContextualHelpType.ChmFile. If empty or
, the default page of the help file will be displayed.
Obtain the URL by:
- Open the chm file and go to the page you want to show.
- Right click on the page, and choose the Properties command.
- In the middle of properties page there is a property called: Address (URL).
The end of the URL contains the topic URL used to open the help file to the correct page.
Here is an example: mk:@MSITStore:C:\RevitAPI2013.chm::/WhatsNew.htm
The help topic URL of this page is "WhatsNew.htm".
Another example: mk:@MSITStore:C:\RevitAPI2013.chm::/html/329b02eb-5ee4-1715-2fbf-2cbbc0d3ff2a.htm
The help topic URL of this page is "html/329b02eb-5ee4-1715-2fbf-2cbbc0d3ff2a.htm".
See Also