ExporterIFCUtilsGetOpeningData Method

Gets the openings data from the element.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<IFCOpeningData> GetOpeningData(
	ExporterIFC exporterIFC,
	Element element,
	Transform lcs,
	IFCRange range
)

Parameters

exporterIFC  ExporterIFC
The exporter.
element  Element
The element.
lcs  Transform
The local coordinate system for the extrusion.
range  IFCRange
The range. This consists of two double values representing the height in Z at the start and the end of the range. If the values are identical the entire element is used.

Return Value

IListIFCOpeningData
The opening data.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also