VertexPair Class

Indices of a pair of vertices in two CurveLoops(one vertex in each loop).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBVertexPair

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class VertexPair : IDisposable

The VertexPair type exposes the following members.

Constructors
 NameDescription
Public methodVertexPair Constructs a new VertexPair from a pair of indices in the curve loops.
Top
Properties
 NameDescription
Public propertyFirst Identifies the first index of VertexPair.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySecond Identifies the second index of VertexPair.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the VertexPair
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A vertex is specified by the index in the CurveLoop of the curve having that vertex as its start point. Indexes start at 0.
See Also