ExternallyTaggedGeometryValidation Class

Provides validation for geometry to be stored in an ExternallyTaggedGeometry.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternallyTaggedGeometryValidation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ExternallyTaggedGeometryValidation

The ExternallyTaggedGeometryValidation type exposes the following members.

Methods
 NameDescription
Public methodStatic memberIsNonSolid Makes sure that the input geometry object is not a Solid.
Public methodStatic memberIsSolid Makes sure that the input geometry object is a Solid.
Public methodStatic memberLacksSubnodes Makes sure that the input geometry object does not have sub-nodes.
Top
See Also