ExternallyTaggedGeometryValidationIsSolid Method |
Makes sure that the input geometry object is a Solid.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsSolid(
GeometryObject geometry
)
Public Shared Function IsSolid (
geometry As GeometryObject
) As Boolean
public:
static bool IsSolid(
GeometryObject^ geometry
)
static member IsSolid :
geometry : GeometryObject -> bool
Parameters
- geometry GeometryObject
-
Geometry object to be validated.
Return Value
Boolean
True if the supplied geometry object is a Solid.
Remarks
This validation is different than negating IsNonSolid().
See Also