SetComparisonResult Enumeration |
An enumerated type listing all the relationship types between two sets of arbitrary nature.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic enum SetComparisonResult
Public Enumeration SetComparisonResult
public enum class SetComparisonResult
MembersMember name | Value | Description |
---|
LeftEmpty | 1 | The left set is empty and the right set is not. |
RightEmpty | 2 | The right set is empty and the left set is not. |
BothEmpty | 3 | Both sets are empty. |
Disjoint | 4 | Both sets are not empty and don't overlap. |
Overlap | 8 | The overlap of two sets is not empty and strict subset of both. |
Subset | 16 | Both sets are not empty and the left set is strict subset of the right. |
Superset | 32 | Both sets are not empty and the left set is strict superset of the right. |
Equal | 64 | Two nonempty sets are equal. |
See Also