ViewApplyViewTemplateParameters Method |
Applies to this view the parameters of the input view that are not controlled by the current view template.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ApplyViewTemplateParameters(
View otherView
)
Public Sub ApplyViewTemplateParameters (
otherView As View
)
public:
void ApplyViewTemplateParameters(
View^ otherView
)
member ApplyViewTemplateParameters :
otherView : View -> unit
Parameters
- otherView View
-
The view whose parameters are to be applied to this view.
It does not have to be a valid template (property IsTemplate can be true or false).
Exceptions
Remarks
Apply the view template parameters is a one-time operation, the association between the views is not preserved.
To get all template parameters call
GetTemplateParameterIds on the template.
To get parameters that are not controlled by the template call
GetNonControlledTemplateParameterIds on the template.
To get current view template of this view use property
ViewTemplateId.
See Also