ViewViewTemplateId Property |
The id of the template view that controls this view's parameters.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId ViewTemplateId { get; set; }
Public Property ViewTemplateId As ElementId
Get
Set
public:
property ElementId^ ViewTemplateId {
ElementId^ get ();
void set (ElementId^ value);
}
member ViewTemplateId : ElementId with get, set
Property Value
ElementId
The id of the template view that controls this view's parameters. InvalidElementId if there is no template set for this view.
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: val is not valid as a view template id for this view.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
Remarks
Parameters controlled by the template cannot be changed directly in this view.
Any change to controlled parameters in the template will cause change of the corresponding parameters in this view.
Use
GetTemplateParameterIds on the template view to get a list of all template parameters.
Use
GetNonControlledTemplateParameterIds on the template view to get parameters that are not controlled by the template.
See Also