TopographyEditScope Constructor |
Instantiates a TopographyEditScope object.
Namespace: Autodesk.Revit.DB.ArchitectureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic TopographyEditScope(
Document document,
string transactionName
)
Public Sub New (
document As Document,
transactionName As String
)
public:
TopographyEditScope(
Document^ document,
String^ transactionName
)
new :
document : Document *
transactionName : string -> TopographyEditScope
Parameters
- document Document
-
The document for which this TopographyEditScope is going to be used.
- transactionName String
-
The name that will appear in the Undo menu in Revit after the TopographyEditScope is successfully committed.
ExceptionsException | Condition |
---|
ArgumentException |
document is not a primary document, it is a linked document.
-or-
document is not a project document.
-or-
transactionName is an empty string.
|
ArgumentNullException |
A non-optional argument was null
|
See Also