StructuralSectionIParallelFlange Class

Defines parameters for I-shape Parallel Flange structural section.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionIParallelFlange : StructuralSectionGeneralI

The StructuralSectionIParallelFlange type exposes the following members.

Constructors
 NameDescription
Public methodStructuralSectionIParallelFlange Creates a new instance of Structural Section I Parallel Flange shape with the associated set of parameters, used to attach to structural element.
Top
Properties
 NameDescription
Public propertyBoltDiameter Maximum bolt hole diameter, in. (mm)
Public propertyBoltSpacing Standard bolt spacing, in. (mm)
Public propertyClearWebHeight Detailing depth between the web toes of the fillets, in.(mm)
Top
Methods
 NameDescription
Top
See Also