StructuralSectionIParallelFlange Class

Defines parameters for I-shape Parallel Flange structural section.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Structure.StructuralSections
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class StructuralSectionIParallelFlange : StructuralSectionGeneralI

The StructuralSectionIParallelFlange type exposes the following members.

Constructors
 NameDescription
Public methodStructuralSectionIParallelFlange Creates a new instance of Structural Section I Parallel Flange shape with the associated set of parameters, used to attach to structural element.
Top
Properties
 NameDescription
Public propertyAnalysisParams Common set of parameters for structural analysis.
(Inherited from StructuralSection)
Public propertyBoltDiameter Maximum bolt hole diameter, in. (mm)
Public propertyBoltSpacing Standard bolt spacing, in. (mm)
Public propertyCentroidHorizontal Distance from centroid to the left extremites along horizontal axis.
(Inherited from StructuralSectionRectangular)
Public propertyCentroidVertical Distance from centroid to the upper extremites along vertical axis.
(Inherited from StructuralSectionRectangular)
Public propertyClearWebHeight Detailing depth between the web toes of the fillets, in.(mm)
Public propertyElasticModulusStrongAxis Elastic section modulus about main strong axis for calculation of bending stresses.
(Inherited from StructuralSection)
Public propertyElasticModulusWeakAxis Elastic section modulus about main weak axis for calculation of bending stresses.
(Inherited from StructuralSection)
Public propertyFlangeFillet Flange Fillet - fillet radius at the flange end.
(Inherited from StructuralSectionGeneralI)
Public propertyFlangeThickness Flange Thickness.
(Inherited from StructuralSectionHotRolled)
Public propertyFlangeThicknessLocation Flange Thickness Location.
(Inherited from StructuralSectionHotRolled)
Public propertyFlangeToeOfFillet Detailing distance from center of web to flange toe of fillet, in. (mm)
(Inherited from StructuralSectionGeneralI)
Public propertyHeight Section height, depth.
(Inherited from StructuralSectionRectangular)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from StructuralSection)
Public propertyMomentOfInertiaStrongAxis Moment of Inertia about main strong axis (I).
(Inherited from StructuralSection)
Public propertyMomentOfInertiaWeakAxis Moment of Inertia about main weak axis (I).
(Inherited from StructuralSection)
Public propertyNameKey Name Key
(Inherited from StructuralSectionRectangular)
Public propertyNominalWeight Unit weight (not mass) per unit length, for self-weight calculation or quantity survey.
(Inherited from StructuralSection)
Public propertyPerimeter Painting surface of the unit length.
(Inherited from StructuralSection)
Public propertyPlasticModulusStrongAxis Plastic section modulus in bending about main strong axis (Z, Wpl).
(Inherited from StructuralSection)
Public propertyPlasticModulusWeakAxis Plastic section modulus in bending about main weak axis.
(Inherited from StructuralSection)
Public propertyPrincipalAxesAngle Rotation angle between the principal axes and cross section reference planes.
(Inherited from StructuralSection)
Public propertySectionArea Cross section area.
(Inherited from StructuralSection)
Public propertySectionNameKey A parameter in structural families which allows for family type identification. This will be used for data mapping during model exchange with another program, namely Advance Steel.
(Inherited from StructuralSection)
Public propertyShearAreaStrongAxis Shear area (reduced extreme shear stress coefficient) in the direction of strong axis (Wq).
(Inherited from StructuralSection)
Public propertyShearAreaWeakAxis Shear area (reduced extreme shear stress coefficient) in the direction of weak axis (Wq).
(Inherited from StructuralSection)
Public propertySlopedFlangeAngle Sloped flange angle. (rad)
(Inherited from StructuralSectionGeneralI)
Public propertyStructuralSectionGeneralShape The general type of structural section shape.
(Inherited from StructuralSection)
Public propertyStructuralSectionShape The type of structural section shape.
(Inherited from StructuralSection)
Public propertyStructuralSectionShapeName A human readable string representing the structural section shape.
(Inherited from StructuralSection)
Public propertyTorsionalModulus Section modulus for calculations of torsion stresses (Ct).
(Inherited from StructuralSection)
Public propertyTorsionalMomentOfInertia Torsional Moment of inertia (J, IT, K), for calculation of torsional deformation
(Inherited from StructuralSection)
Public propertyWarpingConstant Warping constant (Cw, Iomega, H).
(Inherited from StructuralSection)
Public propertyWebFillet Web Fillet - fillet radius between web and flange.
(Inherited from StructuralSectionHotRolled)
Public propertyWebThickness Web Thickness.
(Inherited from StructuralSectionHotRolled)
Public propertyWebThicknessLocation Web Thickness Location.
(Inherited from StructuralSectionHotRolled)
Public propertyWebToeOfFillet Detailing distance from outer face of flange to web toe of fillet, in. (mm)
(Inherited from StructuralSectionGeneralI)
Public propertyWidth Section width.
(Inherited from StructuralSectionRectangular)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from StructuralSection)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBoundarySize Returns size of the section boundary.
(Inherited from StructuralSection)
Public methodGetEnumerator
(Inherited from StructuralSection)
Public methodGetFlangeThicknessInFlangeCenter Returns thickness of flange measured in the 0.25 * (width - webThickess), sometimes used for sections with width > 300 mm.
(Inherited from StructuralSectionGeneralI)
Public methodGetFlangeThicknessInQuarterWidth Returns thickness of flange measured in the 0.25 * width, sometimes used for sections with width <= 300 mm.
(Inherited from StructuralSectionGeneralI)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also