RebarBendingDetailCreate Method |
Creates a new instance of a bending detail.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static Element Create(
Document document,
ElementId viewId,
ElementId reinforcementElementId,
int reinforcementElementSubelementKey,
RebarBendingDetailType bendingDetailType,
XYZ position,
double rotation
)
Public Shared Function Create (
document As Document,
viewId As ElementId,
reinforcementElementId As ElementId,
reinforcementElementSubelementKey As Integer,
bendingDetailType As RebarBendingDetailType,
position As XYZ,
rotation As Double
) As Element
public:
static Element^ Create(
Document^ document,
ElementId^ viewId,
ElementId^ reinforcementElementId,
int reinforcementElementSubelementKey,
RebarBendingDetailType^ bendingDetailType,
XYZ^ position,
double rotation
)
static member Create :
document : Document *
viewId : ElementId *
reinforcementElementId : ElementId *
reinforcementElementSubelementKey : int *
bendingDetailType : RebarBendingDetailType *
position : XYZ *
rotation : float -> Element
Parameters
- document Document
-
Document to which the new element should be added.
- viewId ElementId
-
The id of the view in which the new element should be added.
- reinforcementElementId ElementId
-
The reinforcement element Id that this object will represent.
- reinforcementElementSubelementKey Int32
-
The index of the sub-element from the reinforcement element that this object will represent.
- bendingDetailType RebarBendingDetailType
-
The bending details type used with the resulting object.
- position XYZ
-
The initial position in the view where this object will be created.
- rotation Double
-
The initial rotation in the view for this element.
Return Value
Element
Returns an instance of a bending detail.
Exceptions
See Also