ElementBinding Class

A base class for all types of binding that attach to an element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBBinding
      Autodesk.Revit.DBElementBinding
        Autodesk.Revit.DBInstanceBinding
        Autodesk.Revit.DBTypeBinding

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public abstract class ElementBinding : Binding

The ElementBinding type exposes the following members.

Properties
 NameDescription
Public propertyCategoriesRetrieve or set the categories to which a parameter definition will be bound.
Top
Methods
 NameDescription
Top
Remarks
This base class provides methods that are common to all types of binding that work with elements.
See Also