ProgressChangedEventArgs Class

The event arguments used by the ProgressChanged event.
Inheritance Hierarchy
SystemObject
  SystemEventArgs
    Autodesk.Revit.DB.EventsRevitAPIEventArgs
      Autodesk.Revit.DB.EventsRevitAPISingleEventArgs
        Autodesk.Revit.DB.EventsProgressChangedEventArgs

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ProgressChangedEventArgs : RevitAPISingleEventArgs

The ProgressChangedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyCaption The text from the progress bar caption that describes the operation in progress
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyLowerRange Lower part of progress bar range - always zero
Public propertyPosition Progress bar position - value is always between zero and upperRange and is incremented by one with each event of stage "PositionChanged"
Public propertyStage The current stage of the progress bar
Public propertyUpperRange Upper part of progress bar range - will be any non-zero number
Top
Methods
 NameDescription
Public methodCancel Requests to cancel the progress bar's operation.
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also