ViewSetColorFillSchemeId Method |
Applies color fill scheme to this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetColorFillSchemeId(
ElementId categoryId,
ElementId schemeId
)
Public Sub SetColorFillSchemeId (
categoryId As ElementId,
schemeId As ElementId
)
public:
void SetColorFillSchemeId(
ElementId^ categoryId,
ElementId^ schemeId
)
member SetColorFillSchemeId :
categoryId : ElementId *
schemeId : ElementId -> unit
Parameters
- categoryId ElementId
-
The id of category to apply a color fill scheme element.
- schemeId ElementId
-
The id of the color fill scheme element.
Exceptions
RemarksThere could be at most three [!:Autodesk::Revit::DB::ColorFillScheme] applied in a view:
one for spatial elements (rooms, zones, spaces and areas), one for pipes and one for ducts.
Notes:
- There's at most one scheme activated for all spatial categories.
- For area plan view, the activated spatial scheme category must be OST_Areas and
has the same [!:Autodesk::Revit::DB::AreaScheme] with this view if it is not used as a template.
- To clear one of the above three schemes, use InvalidElementId as the parameter of this function.
- To get list of element categories supportted to be colored in this view, use SupportedColorFillCategoryIds.
- To check whether an specified ElementId could be applied to this view, use CanApplyColorFillScheme(ElementId, ElementId).
See Also