ViewSupportedColorFillCategoryIds Method |
Returns collection of all category ids that correspond to elements that can potentially be colored in this view
according to a color fill scheme. The set may be different depending on the view type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ICollection<ElementId> SupportedColorFillCategoryIds()
Public Function SupportedColorFillCategoryIds As ICollection(Of ElementId)
public:
ICollection<ElementId^>^ SupportedColorFillCategoryIds()
member SupportedColorFillCategoryIds : unit -> ICollection<ElementId>
Return Value
ICollectionElementId
Remarks
All of the possible categories are OST_Rooms, OST_HVAC_Zones, OST_MEPSpaces, OST_Areas, OST_DuctCurves and OST_PipeCurves.
See Also