ViewCanApplyColorFillScheme Method |
Checks if the id can be applied as the scheme id of specified category to this view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanApplyColorFillScheme(
ElementId categoryId,
ElementId schemeId
)
Public Function CanApplyColorFillScheme (
categoryId As ElementId,
schemeId As ElementId
) As Boolean
public:
bool CanApplyColorFillScheme(
ElementId^ categoryId,
ElementId^ schemeId
)
member CanApplyColorFillScheme :
categoryId : ElementId *
schemeId : ElementId -> bool
Parameters
- categoryId ElementId
-
The id of category.
- schemeId ElementId
-
The id of color fill scheme.
Return Value
Boolean
True if the id can be applied as the scheme id of specified category in this view, false otherwise.
Exceptions
RemarksThe input scheme id could be InvalidElementId to clear the scheme for the specified category.
Some examples of returnning false:
- The id is not a color fill scheme id.
- The specified category is not supported by this view.
- The category of scheme is not the same as the specified category.
- The view is area plan but the scheme category is not OST_Areas,
or their [!:Autodesk::Revit::DB::AreaScheme] are not the same.
- Etc.
See Also