CriticalPathIterator Class

An iterator to traverse the critical path in the CriticalPathCollector.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.AnalysisCriticalPathIterator

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CriticalPathIterator : IEnumerator<MEPNetworkSegmentId>

The CriticalPathIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the CriticalPathIterator
Public methodGetCurrent Gets the analytical segment id at the current iterating position.
Public methodIsDone Identifies if the iteration has completed.
Public methodMoveNext Increments the iterator to the next downstream segment on the critical path.
Public methodReset Resets the iterator to the beginning segment.
Top
See Also