DocumentOpenedEventArgs Class

The event arguments used by the DocumentOpened event.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentOpenedEventArgs : RevitAPIPostDocEventArgs

The DocumentOpenedEventArgs type exposes the following members.

Properties
 NameDescription
Public propertyCancellable Indicates whether an event may be cancelled by an event delegate.
(Inherited from RevitAPIEventArgs)
Public propertyDocument The document associated with the event.
(Inherited from RevitAPIPostDocEventArgs)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RevitAPIEventArgs)
Public propertyStatus Indicates whether the action associated with this event succeeded, failed, or was cancelled (by an API event handler).
(Inherited from RevitAPIPostEventArgs)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from RevitAPIEventArgs)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsCancelled Indicates whether the event is being cancelled.
(Inherited from RevitAPIEventArgs)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also