SpatialElementBoundarySubface Class

SpatialElementBoundarySubface represents the geometry boundary information of spatial element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSpatialElementBoundarySubface

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SpatialElementBoundarySubface : IDisposable

The SpatialElementBoundarySubface type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySpatialBoundaryElement Element that gave rise to this room face.
Public propertySubfaceArisesFromElementFace Indicates if the subface is coincident with a portion of a (possibly offset) face of the element.
Public propertySubfaceType Type of the subface.
Public propertyValid Indicates if the subface instance is valid and can be used.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SpatialElementBoundarySubface
Public methodGetBoundingElementFace Returns the face of the bounding element.
Public methodGetSpatialElementFace Returns the face of the spatial element's 3D geometry.
Public methodGetSubface Returns a face that represents the portion of the room face bounded by the boundary element.
Top
See Also