SpatialElementBoundarySubfaceGetSubface Method |
Returns a face that represents the portion of the room face bounded by the boundary element.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
SyntaxPublic Function GetSubface As Face
public:
Face^ GetSubface()
member GetSubface : unit -> Face
Return Value
Face
The sub-face.
Remarks
If the spatial element's face is adjacent to multiple bounding elements (such as two different walls), there will be one sub-face
for each portion of the spatial element's face where it is adjacent to one of those room-bounding elements.
This is equivalent to the return of GetRoomFace() if the entire room face is created by the boundary element.
See Also