LayoutRuleClearSpacing Class

This class indicate the layout rule of a Beam System is Clear-Spacing.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBLayoutRule
      Autodesk.Revit.DBLayoutRuleClearSpacing

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class LayoutRuleClearSpacing : LayoutRule

The LayoutRuleClearSpacing type exposes the following members.

Constructors
 NameDescription
Public methodLayoutRuleClearSpacingConstructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.
Top
Properties
 NameDescription
Public propertyCode exampleIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyJustifyTypeGet or set the type of justification.
Public propertySpacingGet or set the spacing of the beam system.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
To use this type of LayoutRule, the distance between the beams and the justify-type must be set.
Example
private bool LayoutRuleClearSpacingInformation(BeamSystem beamSystem)
{
    //get the layoutRule of the beamsystem
    Autodesk.Revit.DB.LayoutRule layoutRule = beamSystem.LayoutRule;

    string message = "BeamSystem layout rule : " + layoutRule;

    //create a new instance of the LayoutRuleClearSpacing class 
    LayoutRuleClearSpacing myLayoutRuleClearSpacing = 
             new LayoutRuleClearSpacing(10.0, BeamSystemJustifyType.Beginning);

    //set the new layoutRule to the beamsystem
    beamSystem.LayoutRule = myLayoutRuleClearSpacing;

    LayoutRuleClearSpacing clearSpacing = beamSystem.LayoutRule as LayoutRuleClearSpacing;
    if (null == clearSpacing)
    {
        return false;
    }

    //try to get the property value of the beamsystem LayoutRule
    BeamSystemJustifyType justifyType = clearSpacing.JustifyType;

    double spacing = clearSpacing.Spacing;

    message += "\nNew BeamSystem layout rule: " + clearSpacing;
    message += "\nNew BeamSystem spacing: " + spacing;
    message += "\nNew BeamSystem justification: " + justifyType;

    TaskDialog.Show("Revit",message);

    return true;
}
See Also