LayoutRuleClearSpacing Constructor |
Constructor of LayoutRuleFixedDistance. Create LayoutRuleFixedDistance with the values passed in.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic LayoutRuleClearSpacing(
double spacing,
BeamSystemJustifyType justifyType
)
Public Sub New (
spacing As Double,
justifyType As BeamSystemJustifyType
)
public:
LayoutRuleClearSpacing(
double spacing,
BeamSystemJustifyType justifyType
)
new :
spacing : float *
justifyType : BeamSystemJustifyType -> LayoutRuleClearSpacing
Parameters
- spacing Double
- The value of spacing must be in [0, 30000).
- justifyType BeamSystemJustifyType
- The type of the justification, it's corresponding to the items in the element properties dialog.
RemarksThe value of spacing must be in [0, 30000), but in fact the spacing should not be too small or too great.
See Also