BuiltInFailuresEditingFailures Class

Failures related to editing operations.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresEditingFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class EditingFailures

The BuiltInFailuresEditingFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAllInvisibleInPlanViewWarn None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings, as well as any Plan Regions and their settings.
Public propertyStatic memberAllInvisibleInViewWarn None of the created elements are visible in [View Type] View. You may want to check the active view, its Parameters, and Visibility settings.
Public propertyStatic memberBorrowElementsAtRisk Can't obtain permission to edit the element: The Central Model is inaccessible. You can check out worksets at risk, but consider carefully!
Public propertyStatic memberCannotBorrowBusyContention Can't obtain permission to edit the element. The Central Model is busy.
Public propertyStatic memberCannotCheckoutWorksets Can't make workset editable. User '[Borrowers]' has already checked it out.
Public propertyStatic memberCannotDeleteEditedElement Can't delete element that is being edited.
Public propertyStatic memberCannotDeleteEditedElementError Can't delete element that is being edited.
Public propertyStatic memberCannotDeletePredefinedFamilyElement Element is a built-in part of the family definition and cannot be deleted or added to groups.
Public propertyStatic memberCannotDrawInCurrentView Can't draw because Work Plane is at a very sharp angle in this view. Go to another view or redefine the Work Plane.
Public propertyStatic memberCannotDuplicateType Cannot Duplicate Type
Public propertyStatic memberCannotEditDeletedElements Can't edit the element. It was deleted in the Central Model.
Public propertyStatic memberCannotEditDeletedWorkset This action has caused deletion of non-editable Workset ' [Name] '.
Public propertyStatic memberCannotEditEditingElements Can't obtain permission to edit the element: The Central Model is inaccessible and another user is editing the element.
Public propertyStatic memberCannotEditElements Workset is editable, but you can't edit the element until '[Borrowers]' resaves the element to central and relinquishes it and you Reload Latest.
Public propertyStatic memberCannotEditRenamedWorkset Can't edit workset ' [Name] '.
Public propertyStatic memberCannotMirrorInView Must specify Work Plane to mirror in a 3d View.
Public propertyStatic memberCannotMoveElement Can't move element.
Public propertyStatic memberCannotMoveElementWarn Can't move element.
Public propertyStatic memberCannotMoveElementWithoutWorkplane Element(s) need a workplane to be moved in. There's no workplane defined in this view.
Public propertyStatic memberCannotMoveHereInViewError Can't move here at this view angle. Set another Work Plane or adjust the view.
Public propertyStatic memberCannotMoveInView Can't move element because the move plane is seen at a very sharp angle in this View
Public propertyStatic memberCannotMoveInViewError Can't move element because the move plane is seen at a very sharp angle in this View
Public propertyStatic memberCannotMoveLocked Can't move pinned element.
Public propertyStatic memberCannotMoveTogether Can't move these elements at the same time. One of them is restricted to moving in one direction while the other is restricted to moving in a conflicting direction.
Public propertyStatic memberCannotPickHereInCurrentView Can't pick here at this view angle. Set another Work Plane or adjust the view.
Public propertyStatic memberCannotRotateLocked Can't rotate pinned element.
Public propertyStatic memberCannotScaleInView Can't scale because Move Plane is at a very sharp angle in this view. Change view angle or go to another view.
Public propertyStatic memberDeletedRequestedWarn You have deleted elements that other users requested.
Public propertyStatic memberDeleteElementsError [Description]
Public propertyStatic memberDeleteElementsWarn [Description]
Public propertyStatic memberDeletePreventedByGroup Grouped elements can only be deleted when the group is being edited. To delete a member select the group and then click the Edit Group button on the toolbar, then delete the member.
Public propertyStatic memberElementNotEditable One or more elements are not editable.
Public propertyStatic memberElementReversed Element is reversed.
Public propertyStatic memberElementsDeleted Elements were deleted.
Public propertyStatic memberElementsDeletedPastedToKeep Elements were deleted. Use Edit Pasted Elements to keep them.
Public propertyStatic memberElementsNotInPlane Elements don't lie on the same plane.
Public propertyStatic memberElementsWillBeDeleted Elements in [Design Option] will be deleted
Public propertyStatic memberExtendToOtherCrash Can't keep [Type Name] extended to [Type Name].
Public propertyStatic memberExtendToOthersWarn Can't keep [Type Name] extended to [Type Name].
Public propertyStatic memberExtendToOtherWarn Can't keep [Type Name] extended to [Type Name].
Public propertyStatic memberGeneratedByMassing Selected element(s) produced from Massing shape. Once deleted, the selected element(s) will not be regenerated
Public propertyStatic memberHaveNoPermissionToEdit You do not have permission to edit the element.
Public propertyStatic memberHiddenBeamsEditingWarning The beam join being modified contains beam that are not visible. Geometry of visible beams may be affected by hidden beams.
Public propertyStatic memberInvalidArrayObject Some or all of the selected objects can't be created in an Array (for example, a Camera object for a 3D View).
Public propertyStatic memberInvalidElemsInSelection Can't scale elements together.
Public propertyStatic memberLockedDeleted Pinned objects deleted.
Public propertyStatic memberLockedDeletedWarn Pinned objects deleted.
Public propertyStatic memberMirrorProjectSuccess [Action] command has successfully processed [Number] elements
Public propertyStatic memberNElementsDeleted [Number] elements were deleted
Public propertyStatic memberNElementsWrongPosition Review [Number] elements for correct position and shape
Public propertyStatic memberNoRotateMirrorZ Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
Public propertyStatic memberNoRotateMirrorZError Element cannot be mirrored or rotated in a manner that changes its angle relative to the ground.
Public propertyStatic memberOutOfDateElements Workset is editable, but you must Reload Latest before editing the element.
Public propertyStatic memberOwnedByOther Can't edit the element until '[Partition Name]' resaves the element to central and relinquishes it and you Reload Latest.
Public propertyStatic memberOwnElementsOutOfDate You now own the element, but your file is out of date. You must Reload Latest before editing the element.
Public propertyStatic memberPinnedObjectHostDeleted Some pinned objects were deleted because their parent or host object was deleted.
Public propertyStatic memberPinnedObjectNotDeleted Pinned objects were not deleted. To delete them, unpin them before using delete.
Public propertyStatic memberPinnedObjectSomeDeleted Some pinned objects were deleted while others were not.
Public propertyStatic memberPlacementFailed Failed to place component.
Public propertyStatic memberPressShowToSee Press Show to see the element(s); then Ignore or Cancel
Public propertyStatic memberReloadBeforeMakeEditable You must Reload Latest before editing the element.
Public propertyStatic memberReloadNoGood You must Reload Latest before editing the element, but the Central Model is inaccessible or being accessed by another user.
Public propertyStatic memberRPCTurnOffInRealisticWarn None of the placed RPC elements are visible when the visual style is set to Realistic. To see the elements, change VisualStyle of the current view, or change RPC visibility in Graphic Display Options.
Public propertyStatic memberSourceInEditMode Can't transfer project standards while source document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
Public propertyStatic memberTargetInEditMode Can't transfer project standards while target document is in an edit mode. Please exit all edit modes(In-Place Family Edit Mode, Group Edit Mode, Sketch Edit Mode, etc.) and try again.
Public propertyStatic memberTemporaryChangesOutOfDate You must Reload Latest before editing the element. Changes will be temporary, and will not be saved.
Public propertyStatic memberTemporaryChangesTransparentPermissions Permission to edit the element cannot be obtained. Changes will be temporary, and will not be saved.
Public propertyStatic memberTooManyElementsToCheckout Too many elements were attempted to be marked as editable, prompt user to mark workset(s) editable instead
Public propertyStatic memberUnableFilletSpecifiedRadius Unable to create Fillet with the specified radius.
Public propertyStatic memberUnableToMakeSourceWorksetEditable Unable to make the necessary Workset ([Name]) editable in the Linked File in order to change the Shared Coordinates.
Public propertyStatic memberUnableToTransformElement Attempted an invalid element rotate, mirror, or move.
Public propertyStatic memberUnableToTransformElementError Attempted an invalid element rotate, mirror, or move.
Public propertyStatic memberWorksetHasChangedInCentralFile This workset has changed in the Central Model. Please Reload Latest before making this workset editable.
Top
See Also