Draws a split line on the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public SlabShapeCreaseArray DrawSplitLine( SlabShapeVertex startVertex, SlabShapeVertex endVertex ) |
Visual Basic |
---|
Public Function DrawSplitLine ( _ startVertex As SlabShapeVertex, _ endVertex As SlabShapeVertex _ ) As SlabShapeCreaseArray |
Visual C++ |
---|
public: SlabShapeCreaseArray^ DrawSplitLine( SlabShapeVertex^ startVertex, SlabShapeVertex^ endVertex ) |
Parameters
- startVertex
- Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex to start the split line.
- endVertex
- Type: Autodesk.Revit.DB..::..SlabShapeVertex
The vertex to end the split line.
Return Value
The newly created creases.
Remarks
Drawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when the input vertex is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..ArgumentException | Thrown when the input vertex is invalid. |