SlabShapeEditorDrawSplitLine Method |
Note: This API is now obsolete.
Draws a split line on the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")]
public SlabShapeCreaseArray DrawSplitLine(
SlabShapeVertex startVertex,
SlabShapeVertex endVertex
)
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")>
Public Function DrawSplitLine (
startVertex As SlabShapeVertex,
endVertex As SlabShapeVertex
) As SlabShapeCreaseArray
public:
[ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")]
SlabShapeCreaseArray^ DrawSplitLine(
SlabShapeVertex^ startVertex,
SlabShapeVertex^ endVertex
)
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddSplitLine" instead. ")>]
member DrawSplitLine :
startVertex : SlabShapeVertex *
endVertex : SlabShapeVertex -> SlabShapeCreaseArray
Parameters
- startVertex SlabShapeVertex
- The vertex to start the split line.
- endVertex SlabShapeVertex
- The vertex to end the split line.
Return Value
SlabShapeCreaseArrayThe newly created creases.
Exceptions
RemarksDrawing a split line may result in multiple creases, for example when the line crosses existing creases or boundary edges.
See Also