Returns the highest index of the array in the given dimension.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public int GetUpperBound( int dimension ) |
Visual Basic |
---|
Public Function GetUpperBound ( _ dimension As Integer _ ) As Integer |
Visual C++ |
---|
public: int GetUpperBound( int dimension ) |
Parameters
- dimension
- Type: System..::..Int32
The dimension.
Return Value
The highest index of the array in the given dimension.
Remarks
The dimension begins at 0 and must be in the range [0, number of dimensions in the bounds - 1].
This method does not apply to zero dimensional bounds.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The dimension is invalid for these bounds. |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The bounds must have at least one dimension. |