Evaluates and returns the point at the specified parameter along the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2021
Syntax
C# |
---|
public UV Evaluate(
double parameter,
bool normalized
) |
Visual Basic |
---|
Public Function Evaluate ( _
parameter As Double, _
normalized As Boolean _
) As UV |
Visual C++ |
---|
public:
UV^ Evaluate(
double parameter,
bool normalized
) |
Parameters
- parameter
- Type: System..::..Double
The specified parameter along the curve.
- normalized
- Type: System..::..Boolean
If false, parameter is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
The point evaluated along the curve.
Exceptions
See Also