Evaluates and returns the point at the specified parameter along the curve.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic UV Evaluate(
double parameter,
bool normalized
)
Public Function Evaluate (
parameter As Double,
normalized As Boolean
) As UV
public:
UV^ Evaluate(
double parameter,
bool normalized
)
member Evaluate :
parameter : float *
normalized : bool -> UV
Parameters
- parameter Double
-
The specified parameter along the curve.
- normalized Boolean
-
If false, parameter is interpreted as natural parameterization of the curve. If true, param is expected to be in [0,1] interval mapped to the bounds of the curve. Setting to true is valid only if the curve is bound.
Return Value
UV
The point evaluated along the curve.
ExceptionsException | Condition |
---|
ArgumentException |
The given value for parameter is not finite
|
ArgumentOutOfRangeException |
The curve cannot be evaluated as normalized because it is unbound.
-or-
The parameter is not a valid value for normalized evaluation.
|
See Also