Looks up and retrieves the Revit command id with the given id string.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static RevitCommandId LookupPostableCommandId( PostableCommand postableCommand ) |
Visual Basic |
---|
Public Shared Function LookupPostableCommandId ( _ postableCommand As PostableCommand _ ) As RevitCommandId |
Visual C++ |
---|
public: static RevitCommandId^ LookupPostableCommandId( PostableCommand postableCommand ) |
Parameters
- postableCommand
- Type: Autodesk.Revit.UI..::..PostableCommand
The postable command.
Return Value
The Revit command id. Returning nullNothingnullptra null reference (Nothing in Visual Basic) if a command with the given name was not found.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when name is nullNothingnullptra null reference (Nothing in Visual Basic). |