Gets the arcs associated with the plan view of a door.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2014
Syntax
C# |
---|
public static IList<Arc> GetDoor2DArcsFromFamily( Family pFam ) |
Visual Basic |
---|
Public Shared Function GetDoor2DArcsFromFamily ( _ pFam As Family _ ) As IList(Of Arc) |
Visual C++ |
---|
public: static IList<Arc^>^ GetDoor2DArcsFromFamily( Family^ pFam ) |
Parameters
- pFam
- Type: Autodesk.Revit.DB..::..Family
The family.
Return Value
The arcs.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |