Inserts a (key, info) pair into Export line weight table.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void Add( ExportLineweightKey exportLineweightKey, ExportLineweightInfo exportLineweightInfo ) |
Visual Basic |
---|
Public Sub Add ( _ exportLineweightKey As ExportLineweightKey, _ exportLineweightInfo As ExportLineweightInfo _ ) |
Visual C++ |
---|
public: void Add( ExportLineweightKey^ exportLineweightKey, ExportLineweightInfo^ exportLineweightInfo ) |
Parameters
- exportLineweightKey
- Type: Autodesk.Revit.DB..::..ExportLineweightKey
The export line weight Key to be added.
- exportLineweightInfo
- Type: Autodesk.Revit.DB..::..ExportLineweightInfo
The export line weight info to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The key already exists in the table. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |