Sets the function of the specified layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public void SetLayerFunction( int layerIdx, MaterialFunctionAssignment function ) |
Visual Basic |
---|
Public Sub SetLayerFunction ( _ layerIdx As Integer, _ function As MaterialFunctionAssignment _ ) |
Visual C++ |
---|
public: void SetLayerFunction( int layerIdx, MaterialFunctionAssignment function ) |
Parameters
- layerIdx
- Type: System..::..Int32
Index of a layer in the CompoundStructure.
- function
- Type: Autodesk.Revit.DB..::..MaterialFunctionAssignment
The function of the layer.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | The layer index is out of range. -or- A value passed for an enumeration argument is not a member of that enumeration |