Used in class CompoundStructure to specify the function of a layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public enum MaterialFunctionAssignment |
Visual Basic |
---|
Public Enumeration MaterialFunctionAssignment |
Visual C++ |
---|
public enum class MaterialFunctionAssignment |
Members
Member name | Description |
---|---|
None | Priority = 0 This is deprecated and should not be used. |
Structure | Priority = 1 (highest priority) |
Substrate | Priority = 2 |
Insulation | Priority = 3 |
Finish1 | Priority = 4 |
Finish2 | Priority = 5 |
Membrane | A membrane layer must have thickness 0. It is not represented graphically. |
StructuralDeck | Indicates layer is a structural deck. |
Remarks
The function is used primarily to determine
layer priority which affects how layers of distinct elements interact at a join. Typically, layers penetrate
lower priority layers and merge with layers of the same priority.