CompoundStructureSetLayerFunction Method |
Sets the function of the specified layer.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetLayerFunction(
int layerIdx,
MaterialFunctionAssignment function
)
Public Sub SetLayerFunction (
layerIdx As Integer,
function As MaterialFunctionAssignment
)
public:
void SetLayerFunction(
int layerIdx,
MaterialFunctionAssignment function
)
member SetLayerFunction :
layerIdx : int *
function : MaterialFunctionAssignment -> unit
Parameters
- layerIdx Int32
-
Index of a layer in the CompoundStructure.
- function MaterialFunctionAssignment
-
The function of the layer.
ExceptionsException | Condition |
---|
ArgumentOutOfRangeException |
The layer index is out of range.
-or-
A value passed for an enumeration argument is not a member of that enumeration
|
See Also