Creates a new AddInCommandBinding.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public AddInCommandBinding CreateAddInCommandBinding( RevitCommandId revitCommandId ) |
Visual Basic |
---|
Public Function CreateAddInCommandBinding ( _ revitCommandId As RevitCommandId _ ) As AddInCommandBinding |
Visual C++ |
---|
public: AddInCommandBinding^ CreateAddInCommandBinding( RevitCommandId^ revitCommandId ) |
Parameters
- revitCommandId
- Type: Autodesk.Revit.UI..::..RevitCommandId
The Revit command id to identify the command handler you want to replace.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | Thrown when uiApplication or revitCommandId is nullNothingnullptra null reference (Nothing in Visual Basic). |
Autodesk.Revit.Exceptions..::..InvalidOperationException | Thrown when the given command already has been bound. |