Gets a list of valid parameters for the specified category that can be used in the table view.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public static IList<ElementId> GetAvailableParameters( Document cda, ElementId categoryId ) |
Visual Basic |
---|
Public Shared Function GetAvailableParameters ( _ cda As Document, _ categoryId As ElementId _ ) As IList(Of ElementId) |
Visual C++ |
---|
public: static IList<ElementId^>^ GetAvailableParameters( Document^ cda, ElementId^ categoryId ) |
Parameters
- cda
- Type: Autodesk.Revit.DB..::..Document
The document.
- categoryId
- Type: Autodesk.Revit.DB..::..ElementId
The specified element category id.
Return Value
The IDs of all valid parameters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |