TableViewGetAvailableParameters Method

Gets a list of valid parameters for the specified category that can be used in the table view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<ElementId> GetAvailableParameters(
	Document cda,
	ElementId categoryId
)

Parameters

cda  Document
The document.
categoryId  ElementId
The specified element category id.

Return Value

IListElementId
The IDs of all valid parameters.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also