This represents a view that shows a table. Most of the layout data for the table is contained in the TableData class.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)

Syntax

C#
public class TableView : View
Visual Basic
Public Class TableView _
	Inherits View
Visual C++
public ref class TableView : public View

Inheritance Hierarchy

System..::..Object
  Autodesk.Revit.DB..::..Element
    Autodesk.Revit.DB..::..View
      Autodesk.Revit.DB..::..TableView
        Autodesk.Revit.DB.Electrical..::..PanelScheduleView
        Autodesk.Revit.DB..::..ViewSchedule

See Also