Obtains the curve of the wall trimmed or extended according to the end conditions of the wall.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2012
Syntax
C# |
---|
public static Curve GetWallTrimmedCurve( Wall pVWall ) |
Visual Basic |
---|
Public Shared Function GetWallTrimmedCurve ( _ pVWall As Wall _ ) As Curve |
Visual C++ |
---|
public: static Curve^ GetWallTrimmedCurve( Wall^ pVWall ) |
Parameters
- pVWall
- Type: Autodesk.Revit.DB..::..Wall
The wall.
Return Value
The trimmed or extended curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |