Gets the components of a stair or ramp.
Namespace: Autodesk.Revit.DB.IFCAssembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static IFCLegacyStairOrRamp GetLegacyStairOrRampComponents( ExporterIFC exporterIFC, Element element ) |
Visual Basic |
---|
Public Shared Function GetLegacyStairOrRampComponents ( _ exporterIFC As ExporterIFC, _ element As Element _ ) As IFCLegacyStairOrRamp |
Visual C++ |
---|
public: static IFCLegacyStairOrRamp^ GetLegacyStairOrRampComponents( ExporterIFC^ exporterIFC, Element^ element ) |
Parameters
- exporterIFC
- Type: Autodesk.Revit.DB.IFC..::..ExporterIFC
The exporter.
- element
- Type: Autodesk.Revit.DB..::..Element
The legacy stair or ramp element.
Return Value
The LegacyStairOrRamp that contains the components. NULL means the components can't be determined.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |