Subscribe to the ApplicationClosing event to be notified when the Revit application is just about to be closed.
Namespace: Autodesk.Revit.UIAssembly: RevitAPIUI (in RevitAPIUI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2010
Syntax
C# |
---|
public event EventHandler<ApplicationClosingEventArgs> ApplicationClosing |
Visual Basic |
---|
Public Event ApplicationClosing As EventHandler(Of ApplicationClosingEventArgs) |
Visual C++ |
---|
public: event EventHandler<ApplicationClosingEventArgs^>^ ApplicationClosing { void add (EventHandler<ApplicationClosingEventArgs^>^ value); void remove (EventHandler<ApplicationClosingEventArgs^>^ value); } |
Remarks
This event is raised when the Revit application is just about to be closed.
Event is not cancellable. The 'Cancellable' property of event's argument is always False.
No document may be modified at the time of the event.
The sender object of this event is UIControlledApplication object.