Sets the analytical model projection to a preset value.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2015
Syntax
C# |
---|
public void SetProjection( AnalyticalElementSelector selector, StickElementProjectionY projectionY, StickElementProjectionZ projectionZ ) |
Visual Basic |
---|
Public Sub SetProjection ( _ selector As AnalyticalElementSelector, _ projectionY As StickElementProjectionY, _ projectionZ As StickElementProjectionZ _ ) |
Visual C++ |
---|
public: void SetProjection( AnalyticalElementSelector selector, StickElementProjectionY projectionY, StickElementProjectionZ projectionZ ) |
Parameters
- selector
- Type: Autodesk.Revit.DB.Structure..::..AnalyticalElementSelector
End of the analytical model.
- projectionY
- Type: Autodesk.Revit.DB.Structure..::..StickElementProjectionY
Preset value for Analytical Model Stick projection Y.
- projectionZ
- Type: Autodesk.Revit.DB.Structure..::..StickElementProjectionZ
Preset value for Analytical Model Stick projection Z.
Remarks
This should be used if setting the analytical model projection to something
other than a Plane.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |