Presets for given Analytical Projection.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Syntax
C# |
---|
public enum StickElementProjectionZ |
Visual Basic |
---|
Public Enumeration StickElementProjectionZ |
Visual C++ |
---|
public enum class StickElementProjectionZ |
Members
Member name | Description |
---|---|
LocationLine | Location Line. |
Top | Horizontally, corresponds to top of physical model. |
Center | Horizontally, center of physical model. |
Bottom | Horizontally, corresponds to bottom of physical model. |
Plane | Use a Plane for projection (e.g., Grid, Level). |
Varies | Projection types are different at each end. |