Identifies if the fluid type is in use.
Namespace: Autodesk.Revit.DB.PlumbingAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013
Syntax
C# |
---|
public static bool IsFluidInUse( Document document, ElementId fluidId ) |
Visual Basic |
---|
Public Shared Function IsFluidInUse ( _ document As Document, _ fluidId As ElementId _ ) As Boolean |
Visual C++ |
---|
public: static bool IsFluidInUse( Document^ document, ElementId^ fluidId ) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document.
- fluidId
- Type: Autodesk.Revit.DB..::..ElementId
The id of the fluid type.
Return Value
True if the fluid type is in use. False if the fluid type is not in use.
Remarks
If a fluid type is in use, it cannot be deleted.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |