Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface, including Plane and CylSurf.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since:
2016
Syntax
Parameters
- surface
- Type: Autodesk.Revit.DB..::..Surface
The Revit surface defining the geometry.
This BRepBuilderSurfaceGeometry stores a copy of the input surface.
- surfaceEnvelope
- Type: Autodesk.Revit.DB..::..BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface.
This is typically used to identify the domain of the face that references the surface in question.
Expected to either be null or define a valid domain.
Exceptions
See Also