A mathematical representation of a surface.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2016
Syntax
C# |
---|
public class Surface : IDisposable |
Visual Basic |
---|
Public Class Surface _ Implements IDisposable |
Visual C++ |
---|
public ref class Surface : IDisposable |
Remarks
This geometric object is not bounded by edges or edge loops. A bounded surface obtained from a Revit element
will be represented by a Face instead.
Inheritance Hierarchy
System..::..Object
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..ConicalSurface
Autodesk.Revit.DB..::..CylindricalSurface
Autodesk.Revit.DB..::..HermiteSurface
Autodesk.Revit.DB..::..OffsetSurface
Autodesk.Revit.DB..::..Plane
Autodesk.Revit.DB..::..RevolvedSurface
Autodesk.Revit.DB..::..RuledSurface
Autodesk.Revit.DB..::..Surface
Autodesk.Revit.DB..::..ConicalSurface
Autodesk.Revit.DB..::..CylindricalSurface
Autodesk.Revit.DB..::..HermiteSurface
Autodesk.Revit.DB..::..OffsetSurface
Autodesk.Revit.DB..::..Plane
Autodesk.Revit.DB..::..RevolvedSurface
Autodesk.Revit.DB..::..RuledSurface