BRepBuilderSurfaceGeometryCreate Method

Construct BRepBuilderSurfaceGeometry based on a permitted Revit Surface.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static BRepBuilderSurfaceGeometry Create(
	Surface surface,
	BoundingBoxUV surfaceEnvelope
)

Parameters

surface  Surface
The Revit surface defining the geometry. This BRepBuilderSurfaceGeometry stores a copy of the input surface.
surfaceEnvelope  BoundingBoxUV
Envelope of the surface in the uv parametric domain. Defines the domain of interest for the created surface. This is typically used to identify the domain of the face that references the surface in question. Expected to either be null or define a valid domain.

Return Value

BRepBuilderSurfaceGeometry
Exceptions
ExceptionCondition
ArgumentException A surface of this type cannot be used as a part of the geometry generated by BRepBuilder.
ArgumentNullException A non-optional argument was null
Remarks
Permitted Surface types are those for which IsPermittedSurfaceType(Surface) returns true.
See Also