Sets the value of the property.
Namespace: Autodesk.Revit.DB.VisualAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2018.1
Syntax
C# |
---|
public void SetValueAsDoubles( IList<double> value ) |
Visual Basic |
---|
Public Sub SetValueAsDoubles ( _ value As IList(Of Double) _ ) |
Visual C++ |
---|
public: void SetValueAsDoubles( IList<double>^ value ) |
Parameters
- value
- Type: System.Collections.Generic..::..IList<(Of <(<'Double>)>)>
The new value as doubles.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..ArgumentException | The input value is invalid for this AssetPropertyDoubleArray4d property. |
Autodesk.Revit.Exceptions..::..ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions..::..InvalidOperationException | The asset property is not editable. |