Gets the rectangle that represents the extent (in 2D) of the Revit view where rendering takes place.
Namespace: Autodesk.Revit.DB.DirectContext3DAssembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2017
Syntax
C# |
---|
public static Rectangle GetViewRectangle() |
Visual Basic |
---|
Public Shared Function GetViewRectangle As Rectangle |
Visual C++ |
---|
public: static Rectangle^ GetViewRectangle() |
Return Value
The view rectangle.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions..::..InvalidOperationException | This DrawContext is not available because Revit is not currently rendering. In general, this DrawContext must be used in the scope of the RenderScene() callback of IDirectContext3DServer. |